It is currently Mon May 21, 2018 7:37 am




Post new topic Reply to topic  [ 13 posts ] 
 Help with rpgxEF. 
Author Message

Joined: Sat Jan 05, 2013 2:28 pm
Posts: 4
Post Help with rpgxEF.
So, I'm not sure how many people still read this board, but there's an upgraded engine in development called rpgxEF. It's been built from the ground up to support the RPG-X mod. I've been trying to install this on my server without any success. I've put the new Linux binaries in the server's root game folder and taken the necessary set-up steps, but the Usermin control panel says it can't locate the file.


Sat Jan 05, 2013 5:13 pm
Profile
User avatar

Joined: Fri Nov 09, 2007 5:44 pm
Posts: 28
Location: Scotland, UK
Post Re: Help with rpgxEF.
Hey man, I'm friends with Brex and he'd asked me if I could lend a hand.

So far, I've had no luck I'm afraid. I'm currently trying out a few different things and will let you know how I get on. It's strange, because when I'd used a version of ioCow compiled by Marcin a few years back, that worked without a hitch.


Mon Jan 07, 2013 4:11 pm
Profile

Joined: Sat Jan 05, 2013 2:28 pm
Posts: 4
Post Re: Help with rpgxEF.
khamseen wrote:
Hey man, I'm friends with Brex and he'd asked me if I could lend a hand.

So far, I've had no luck I'm afraid. I'm currently trying out a few different things and will let you know how I get on. It's strange, because when I'd used a version of ioCow compiled by Marcin a few years back, that worked without a hitch.


Yeah, it's very strange. I don't have the files on my server now because ioEF can't start with them cluttering up the folders, but attempting to set the server_exec to rpgxEFded.i386 just results in a "file not found" error, even with everything in the root and RPG-X2 folders.


Mon Jan 07, 2013 6:21 pm
Profile
User avatar

Joined: Fri Nov 09, 2007 5:44 pm
Posts: 28
Location: Scotland, UK
Post Re: Help with rpgxEF.
Serris wrote:
Yeah, it's very strange. I don't have the files on my server now because ioEF can't start with them cluttering up the folders, but attempting to set the server_exec to rpgxEFded.i386 just results in a "file not found" error, even with everything in the root and RPG-X2 folders.


Where do you see the 'file not found' error? I haven't seen that come up, but the server simply fails to actually load anything. It's rather infuriating not getting any more info than, it didn't load...

Did the support team have any better ideas other than telling you what to set 'server_exec' to, which you already knew?


Tue Jan 08, 2013 12:38 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Thu Mar 25, 2004 1:04 am
Posts: 3542
Post Re: Help with rpgxEF.
To run the new version, after you install the 64 bit binary and necessary files, use the following setting for your control panel:

server_exec="rpgxEFded.x86_64"

I believe we got it working over a support ticket. Can anyone confirm?

By the way, you can always have multiple directories and versions of the same game. Simply copy the directory, rename, and change the control panel settings accordingly. The reason we have a Start / Edit Custom Config 1 through 4 is so that you can quickly switch versions instead of having to edit the control panel each time.

_________________
Billing, Sales, and Official Support

Helpdesk


Tue Jan 08, 2013 1:29 pm
Profile

Joined: Tue Jan 08, 2013 1:05 pm
Posts: 3
Post Re: Help with rpgxEF.
Hey guys,

Serris and I (mostly Serris) have found a solution:

Make sure you are using rpgxEFded86_64, not i386, and then ALSO ensure you're using the x64 version of the rpgxEF LIBRARIES, which are separate and go in the RPG-X2 directory.

If both of these components are not x64, the server will give you mismatch errors or not start at all.

Hope this helps everyone!


Tue Jan 08, 2013 3:35 pm
Profile
User avatar

Joined: Fri Nov 09, 2007 5:44 pm
Posts: 28
Location: Scotland, UK
Post Re: Help with rpgxEF.
escapedturkey wrote:
To run the new version, after you install the 64 bit binary and necessary files, use the following setting for your control panel:

server_exec="rpgxEFded.x86_64"

I believe we got it working over a support ticket. Can anyone confirm?

By the way, you can always have multiple directories and versions of the same game. Simply copy the directory, rename, and change the control panel settings accordingly. The reason we have a Start / Edit Custom Config 1 through 4 is so that you can quickly switch versions instead of having to edit the control panel each time.


Great to know, looks like they've got it working so I'll be updating my server too. :)
Also, that's very good to know about multiple copies of the same game as I suspected that was possible but didn't want to do it in case it violated my server terms or something haha. Means I can leave the vanilla install where it is.

TLOVeritas wrote:
Hey guys,

Serris and I (mostly Serris) have found a solution:

Make sure you are using rpgxEFded86_64, not i386, and then ALSO ensure you're using the x64 version of the rpgxEF LIBRARIES, which are separate and go in the RPG-X2 directory.

If both of these components are not x64, the server will give you mismatch errors or not start at all.

Hope this helps everyone!


Thanks for letting us know it's working. I'd been having another play around this afternoon and couldn't get there. Didn't think about trying the x64 version.


Tue Jan 08, 2013 6:30 pm
Profile

Joined: Tue Jan 08, 2013 1:05 pm
Posts: 3
Post Re: Help with rpgxEF.
Yep! I'm also working on updating my all-in-one RPG-X installer, RPGXCE, to be rpgxEF compatible. Initial tests are very promising.


Tue Jan 08, 2013 7:31 pm
Profile
User avatar

Joined: Fri Nov 09, 2007 5:44 pm
Posts: 28
Location: Scotland, UK
Post Re: Help with rpgxEF.
It's a shame that like ioEF it has shader issues and screws up lightmaps completely. I was planning on releasing my updated Relativity and my new ship map after playing in game again the other day, but after seeing what rpgxef and ioEF do to them, I have put off once again.


Wed Jan 09, 2013 11:15 am
Profile

Joined: Sat Jan 05, 2013 2:28 pm
Posts: 4
Post Re: Help with rpgxEF.
escapedturkey wrote:
To run the new version, after you install the 64 bit binary and necessary files, use the following setting for your control panel:

server_exec="rpgxEFded.x86_64"

I believe we got it working over a support ticket. Can anyone confirm?

By the way, you can always have multiple directories and versions of the same game. Simply copy the directory, rename, and change the control panel settings accordingly. The reason we have a Start / Edit Custom Config 1 through 4 is so that you can quickly switch versions instead of having to edit the control panel each time.


Thank you very much! Your solution worked.

khamseen wrote:
It's a shame that like ioEF it has shader issues and screws up lightmaps completely. I was planning on releasing my updated Relativity and my new ship map after playing in game again the other day, but after seeing what rpgxef and ioEF do to them, I have put off once again.


That's a shame. Compared to Yager-E and the stock Poseidon maps, Relativity's lightmaps fared much better. Will you let me know if you decide to change your mind?


Wed Jan 09, 2013 4:06 pm
Profile
User avatar

Joined: Fri Nov 09, 2007 5:44 pm
Posts: 28
Location: Scotland, UK
Post Re: Help with rpgxEF.
Serris wrote:
escapedturkey wrote:
That's a shame. Compared to Yager-E and the stock Poseidon maps, Relativity's lightmaps fared much better. Will you let me know if you decide to change your mind?


Yeah, Relativity doesn't seem too bad, but my newer map, The Tempest, is like walking around with bloom on full, everything is just hideously over bright. I've actually opened up NetRadiant for the first time in years to see if I can make it any darker in the hopes that maybe that will help counter the effects without making it too dark for Vanilla haha.


Wed Jan 09, 2013 4:52 pm
Profile

Joined: Sat Jan 05, 2013 2:28 pm
Posts: 4
Post Re: Help with rpgxEF.
Okay, since 2.3 beta 1 is out now, I've run into an entirely new problem! I've re-purposed my second server for testing this. It finds the new rpgxEFded.x86_64 and .so files, but it's just refusing to boot. I can't really think of anything that might be causing this. Has anyone else run a 2.3 beta 1 server successfully before?

For reference, here are screenshots of the game directory and the RPG-X2 folder:

Image
Image

QStat doesn't report any errors finding the executable, it just constantly says 108.178.55.167: DOWN. I don't know if the start-up command is being properly processed.


Tue Aug 27, 2013 1:57 pm
Profile
Site Admin
Site Admin
User avatar

Joined: Thu Mar 25, 2004 1:04 am
Posts: 3542
Post Re: Help with rpgxEF.
Please create a support ticket. We can run the command line to provide you any errors that we encounter. 8)

_________________
Billing, Sales, and Official Support

Helpdesk


Tue Aug 27, 2013 5:01 pm
Profile
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB | Based on the theme by Vjacheslav Trushkin